aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2011-11-15 16:04:46 +0100
committerThomas White <taw@physics.org>2012-02-22 15:27:40 +0100
commit2c238039c2efda1788ea72c9fb41ff354acc8e97 (patch)
tree34c30c1a29e5bbbc50d25cb62aabe05cb196abb1 /Makefile.am
parent3c896e8741763b66fa056d6c8d79557225e66ad2 (diff)
Move the "indexed reflection array" thing to where it can't do any harm
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 5e7d8d19..f0e5053d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -35,12 +35,14 @@ LDADD += $(top_builddir)/libcrystfel/libcrystfel.la
src_partial_sim_SOURCES = src/partial_sim.c
-src_pattern_sim_SOURCES = src/pattern_sim.c
+src_pattern_sim_SOURCES = src/pattern_sim.c src/diffraction.c \
+ src/diffraction-gpu.c
if HAVE_OPENCL
TESTS += tests/gpu_sim_check
noinst_PROGRAMS += tests/gpu_sim_check
-tests_gpu_sim_check_SOURCES = tests/gpu_sim_check.c
+tests_gpu_sim_check_SOURCES = tests/gpu_sim_check.c src/diffraction.c \
+ src/diffraction-gpu.c
endif
src_process_hkl_SOURCES = src/process_hkl.c
@@ -88,7 +90,7 @@ EXTRA_DIST += src/dw-hdfsee.h src/hdfsee.h src/render_hkl.h \
src/post-refinement.h src/hrs-scaling.h src/scaling-report.h
crystfeldir = $(datadir)/crystfel
-crystfel_DATA = data/diffraction.cl data/defs.h data/hdfsee.ui
+crystfel_DATA = data/diffraction.cl data/hdfsee.ui
EXTRA_DIST += $(crystfel_DATA)