aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2011-11-15 17:31:09 +0100
committerThomas White <taw@physics.org>2012-02-22 15:27:41 +0100
commit4c65ae0588c789e9f15eb1f0c324224301082263 (patch)
tree6d06f339697dc16b8556ac2b4bd8318534497429 /Makefile.am
parentd3ec66174fbfcb3780e106ca25134fd58a45506c (diff)
Separate CFLAGS and LIBS for libcrystfel and main
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index cbf0aec6..6a81a78c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -27,11 +27,11 @@ if HAVE_CAIRO
bin_PROGRAMS += src/render_hkl
endif
-AM_CFLAGS = -Wall
+AM_CFLAGS = -Wall @MAIN_CFLAGS@
AM_CPPFLAGS = -DDATADIR=\""$(datadir)"\" -I$(top_builddir)/lib
AM_CPPFLAGS += -I$(top_srcdir)/lib
LDADD = $(top_builddir)/lib/libgnu.a @IGNORE_UNUSED_LIBRARIES_CFLAGS@
-LDADD += $(top_builddir)/libcrystfel/libcrystfel.la
+LDADD += $(top_builddir)/libcrystfel/libcrystfel.la @MAIN_LIBS@
src_partial_sim_SOURCES = src/partial_sim.c