aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2011-11-15 16:58:29 +0100
committerThomas White <taw@physics.org>2012-02-22 15:27:40 +0100
commit6472f65d59a2ebcebdc908d4717a8e278596a96a (patch)
tree872fb95125f9318796afc4e7335b1336f3062b47 /Makefile.am
parentfa010578c3ad146e6c7c89305fe57394eaff4b92 (diff)
Don't try to compile OpenCL stuff without OpenCL
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 3de1cdda..e122098f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -35,12 +35,12 @@ LDADD += $(top_builddir)/libcrystfel/libcrystfel.la
src_partial_sim_SOURCES = src/partial_sim.c
-src_pattern_sim_SOURCES = src/pattern_sim.c src/diffraction.c src/cl-utils.c \
- src/diffraction-gpu.c
+src_pattern_sim_SOURCES = src/pattern_sim.c src/diffraction.c
+
if HAVE_OPENCL
+src_pattern_sim_SOURCES += src/cl-utils.c src/diffraction-gpu.c
TESTS += tests/gpu_sim_check
noinst_PROGRAMS += tests/gpu_sim_check
-
tests_gpu_sim_check_SOURCES = tests/gpu_sim_check.c src/diffraction.c \
src/diffraction-gpu.c
endif