aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2011-06-30 16:02:08 +0200
committerThomas White <taw@physics.org>2012-02-22 15:27:31 +0100
commitd87ba39fc8d6356dcf4615e5f9c2a2589bc0ab84 (patch)
treed36e7315268cd9f04c09b3f9d7972cdb0b76b7e4 /Makefile.am
parenta7639bf3c053d0deee363d9780ff9bc2e643d1f2 (diff)
Add contrib/alter_stream
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 2c4672ce..489a5dd2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,7 +5,8 @@ ACLOCAL_AMFLAGS = -I m4
bin_PROGRAMS = src/pattern_sim src/process_hkl src/get_hkl src/indexamajig \
src/compare_hkl src/powder_plot src/render_hkl \
src/calibrate_detector src/partialator \
- src/check_hkl src/sum_stack src/partial_sim
+ src/check_hkl src/sum_stack src/partial_sim \
+ contrib/alter_stream
noinst_PROGRAMS = tests/list_check tests/integration_check \
tests/pr_gradient_check
@@ -127,6 +128,12 @@ src_cubeit_SOURCES = src/cubeit.c src/cell.c src/hdf5-file.c src/utils.c \
src/reflist.c src/reflist-utils.c
endif
+contrib_alter_stream_SOURCES = contrib/alter_stream.c src/stream.c src/image.c \
+ src/thread-pool.c src/detector.c src/utils.c \
+ src/cell.c src/reflist-utils.c src/reflist.c \
+ src/symmetry.c src/hdf5-file.c \
+ src/beam-parameters.c src/geometry.c src/peaks.c
+
tests_list_check_SOURCES = tests/list_check.c src/reflist.c src/thread-pool.c \
src/utils.c