aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2011-07-08 17:56:15 +0200
committerThomas White <taw@physics.org>2012-02-22 15:27:32 +0100
commitf2473f3f3c29b6d4b1193393c77ca4d21921be4e (patch)
tree7ddf1d229ca8672df4410cc6ff89eeb6a0461433 /Makefile.am
parent06238f6deee66dc1a90920f335cab5af88e6693c (diff)
Add scaling report skeleton
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 489a5dd2..a2fdb3c0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -121,6 +121,10 @@ src_partialator_SOURCES = src/partialator.c src/cell.c src/hdf5-file.c \
src/symmetry.c src/post-refinement.c \
src/hrs-scaling.c src/reflist.c
+if HAVE_CAIRO
+src_partialator_SOURCES += src/scaling-report.c
+endif
+
if BUILD_CUBEIT
src_cubeit_SOURCES = src/cubeit.c src/cell.c src/hdf5-file.c src/utils.c \
src/detector.c src/render.c src/filters.c src/image.c \
@@ -158,7 +162,7 @@ EXTRA_DIST += src/cell.h src/hdf5-file.h src/image.h src/utils.h \
src/symmetry.h src/povray.h src/index-priv.h src/geometry.h \
src/render_hkl.h src/stream.h src/thread-pool.h \
src/beam-parameters.h src/post-refinement.h src/hrs-scaling.h \
- src/reflist.h
+ src/reflist.h src/scaling-report.h
crystfeldir = $(datadir)/crystfel
crystfel_DATA = data/diffraction.cl data/defs.h data/hdfsee.ui