aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas White <taw@bitwiz.org.uk>2009-10-12 18:07:01 +0200
committerThomas White <taw@bitwiz.org.uk>2009-10-12 18:07:01 +0200
commitb86edb609f916af353666b6783ca398e39d1cdf1 (patch)
tree7cc6c13098167524a68e3c4ce6d5c4c264c1acb1 /configure.ac
Initial import of template_index
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 00000000..9a495108
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,21 @@
+dnl Process this file with autoconf to produce a configure script.
+
+AC_INIT(template_index, 0.1.0, thomas.white@desy.de)
+VERSION=AC_PACKAGE_VERSION
+
+AM_CONFIG_HEADER(config.h)
+AM_INIT_AUTOMAKE(template_index, "$VERSION")
+
+AC_PROG_CC
+AC_PROG_AWK
+AC_PROG_INSTALL
+AC_PROG_LN_S
+
+AC_HEADER_STDC
+AC_CHECK_HEADERS([fcntl.h stdlib.h string.h unistd.h])
+AC_C_CONST
+AC_FUNC_MALLOC
+AC_TYPE_SIGNAL
+AC_CHECK_FUNCS([strdup])
+
+AC_OUTPUT(Makefile src/Makefile)