aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas White <taw@bitwiz.org.uk>2010-12-08 16:18:37 -0700
committerThomas White <taw@physics.org>2012-02-22 15:27:08 +0100
commit4e841e7a8592ca406235ecf181245dba0b0c5e30 (patch)
tree1da15eaa11564e4198fed623d067c896752801b6 /configure.ac
parente5c2085dafa95f7d9f82fe4a8bb79012cb0f3166 (diff)
Make PNG and TIFF tests work
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2a58233a..07572696 100644
--- a/configure.ac
+++ b/configure.ac
@@ -100,7 +100,10 @@ AC_ARG_ENABLE([png],
AS_IF([test "x$enable_png" != "xno"],
[
AC_MSG_RESULT([yes])
- PKG_CHECK_MODULES([libPNG], [libpng >= 1.2.0], [havelibpng=true])
+ PKG_CHECK_MODULES([libPNG], [libpng >= 1.2.0],
+ [
+ AC_DEFINE([HAVE_LIBPNG], [1], [Define to 1 if libPNG is available])
+ ])
],[
AC_MSG_RESULT([no])
])
@@ -117,6 +120,7 @@ AS_IF([test "x$enable_tiff" != "xno"],
LIBTIFF_LIBS="-L$withval/lib -ltiff"],
[LIBTIFF_LIBS="-ltiff"])
AC_MSG_RESULT([yes])
+ AC_DEFINE([HAVE_TIFF], [1], [Define to 1 if libTIFF is available])
],
[
AC_MSG_RESULT([no])