aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2011-03-09 16:24:27 +0100
committerThomas White <taw@physics.org>2012-02-22 15:27:19 +0100
commit6b67dc7ba7301274167519d5fcc38161b1a791a9 (patch)
tree51eafbd2a92cbf5b005eeba2629d5327d44c63ce /configure.ac
parente33dac04453ee0b759af5560dd4758f6cfc7eb67 (diff)
Better libTIFF test
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index e35a7dda..c9f410da 100644
--- a/configure.ac
+++ b/configure.ac
@@ -157,13 +157,17 @@ AS_IF([test "x$enable_tiff" != "xno"],
[
LIBTIFF_CFLAGS="-I$withval/include"
LIBTIFF_LIBS="-L$withval/lib -ltiff"
+ have_libtiff=true
], [
- LIBTIFF_LIBS="-ltiff"
+ AC_CHECK_LIB([tiff], [TIFFOpen], [], [have_libtiff=true])
])
- AC_DEFINE([HAVE_TIFF], [1], [Define to 1 if libTIFF is available])
], [
AC_MSG_RESULT([no])
])
+AS_IF([test x$have_libtiff = xtrue],
+[
+ AC_DEFINE([HAVE_TIFF], [1], [Define to 1 if libTIFF is available])
+])
AC_MSG_CHECKING([whether to use Cairo])