aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas White <taw@bitwiz.org.uk>2011-01-16 19:10:13 +0100
committerThomas White <taw@physics.org>2012-02-22 15:27:11 +0100
commit6f2c69fde931686c7400595ae162bccdd899de51 (patch)
treec8d427ab2261e0f217f1af95ad43a9ab56d070c5 /configure.ac
parentd1d03a3ed5869dac9060bb23dfc71cd8433c36ee (diff)
Use pkg-config to get GSL flags
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 4 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index da550a85..9503acfa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -30,11 +30,10 @@ AC_ARG_WITH(hdf5,
[HDF5_LIBS="-lhdf5"])
-AC_ARG_WITH(gsl,
-[AS_HELP_STRING([--with-gsl], [specify location of GSL])],
-[GSL_CFLAGS="-I$withval/include"
- GSL_LIBS="-L$withval/lib -lgsl -lgslcblas"],
-[GSL_LIBS="-lgsl -lgslcblas"])
+PKG_CHECK_MODULES([GSL], [gsl], [],
+[
+ AC_ERROR([GSL is required])
+])
AC_ARG_ENABLE(opencl, AS_HELP_STRING([--enable-opencl], [Enable the use of OpenCL]))