aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 773d246e..660f3233 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -87,6 +87,11 @@ add_subdirectory(libcrystfel)
enable_testing()
add_subdirectory(tests)
+# crystfel.pc
+configure_file(libcrystfel/crystfel.pc.in crystfel.pc)
+install(FILES ${CMAKE_BINARY_DIR}/crystfel.pc
+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
+
# API docs
find_package(GtkDoc 1.25)
if (GTKDOC_FOUND)