aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt32
1 files changed, 30 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e13d9c5a..f6546cb2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -313,5 +313,33 @@ install(TARGETS
RUNTIME DESTINATION bin
LIBRARY DESTINATION lib
RESOURCE DESTINATION share/crystfel
- )
-
+)
+
+install(FILES
+ doc/man/ambigator.1
+ doc/man/cell_explorer.1
+ doc/man/check_hkl.1
+ doc/man/compare_hkl.1
+ doc/man/geoptimiser.1
+ doc/man/get_hkl.1
+ doc/man/hdfsee.1
+ doc/man/indexamajig.1
+ doc/man/list_events.1
+ doc/man/partialator.1
+ doc/man/partial_sim.1
+ doc/man/pattern_sim.1
+ doc/man/process_hkl.1
+ doc/man/render_hkl.1
+ doc/man/whirligig.1
+ DESTINATION ${CMAKE_INSTALL_MANDIR}/man1
+)
+
+install(FILES
+ doc/man/crystfel.7
+ DESTINATION ${CMAKE_INSTALL_MANDIR}/man7
+)
+
+install(FILES
+ doc/man/crystfel_geometry.5
+ DESTINATION ${CMAKE_INSTALL_MANDIR}/man5
+)