aboutsummaryrefslogtreecommitdiff
path: root/libcrystfel/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'libcrystfel/meson.build')
-rw-r--r--libcrystfel/meson.build7
1 files changed, 1 insertions, 6 deletions
diff --git a/libcrystfel/meson.build b/libcrystfel/meson.build
index 35893115..dc0fe2bf 100644
--- a/libcrystfel/meson.build
+++ b/libcrystfel/meson.build
@@ -12,11 +12,6 @@ if fftwdep.found()
conf_data.set10('HAVE_FFTW', 1)
endif
-ncursesdep = dependency('ncurses', required: false)
-if ncursesdep.found()
- conf_data.set10('HAVE_CURSES', 1)
-endif
-
xgandalfdep = dependency('xgandalf',
required: false,
fallback: ['xgandalf', 'xgandalf_dep'])
@@ -139,7 +134,7 @@ libcrystfel = library('crystfel', [libcrystfel_sources, libcrystfel_versionc],
include_directories: [libcrystfel_includes,
libcrystfel_conf_inc],
dependencies: [mdep, utildep, fftwdep, gsldep, zlibdep,
- hdf5dep, pthreaddep, ncursesdep,
+ hdf5dep, pthreaddep,
xgandalfdep, pinkindexerdep, fdipdep,
ccp4dep, msgpackdep],
install: true)