aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 8 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index b7ba1c4b..21bfa2f6 100644
--- a/meson.build
+++ b/meson.build
@@ -94,6 +94,11 @@ if cc.has_function('clock_gettime', prefix : '#include <time.h>')
conf_data.set10('HAVE_CLOCK_GETTIME', 1)
endif
+ccp4dep = dependency('libccp4c', required: false)
+if ccp4dep.found()
+ conf_data.set10('HAVE_LIBCCP4', 1)
+endif
+
# ************************ libcrystfel (subdir) ************************
subdir('libcrystfel')
@@ -231,8 +236,10 @@ if gtkdep.found()
gui_sources += 'src/gui_backend_slurm.c'
endif
+
executable('crystfel', gui_sources,
- dependencies : [mdep, libcrystfeldep, gtkdep, gsldep, slurmdep],
+ dependencies : [mdep, libcrystfeldep, gtkdep, gsldep, slurmdep,
+ ccp4dep],
install : true,
install_rpath: '$ORIGIN/../lib64/:$ORIGIN/../lib')