aboutsummaryrefslogtreecommitdiff
path: root/tools/perf/scripts/perl/Perf-Trace-Util/Makefile.PL
diff options
context:
space:
mode:
authorIngo Molnar <mingo@elte.hu>2009-12-03 20:10:35 +0100
committerIngo Molnar <mingo@elte.hu>2009-12-03 20:10:42 +0100
commit23ba90e328fd2326378447cafafa47defdfc83c2 (patch)
treec1febaf468e0255eedfbedf07a07d8178a0b5ac9 /tools/perf/scripts/perl/Perf-Trace-Util/Makefile.PL
parente859cf8656043f158b4004ccc8cbbf1ba4f97177 (diff)
parent8ea339adc0a48236008e59dd21564d71c37b331c (diff)
Merge branch 'perf/scripting' into perf/core
Merge reason: it's ready for v2.6.33. Signed-off-by: Ingo Molnar <mingo@elte.hu>
Diffstat (limited to 'tools/perf/scripts/perl/Perf-Trace-Util/Makefile.PL')
-rw-r--r--tools/perf/scripts/perl/Perf-Trace-Util/Makefile.PL17
1 files changed, 17 insertions, 0 deletions
diff --git a/tools/perf/scripts/perl/Perf-Trace-Util/Makefile.PL b/tools/perf/scripts/perl/Perf-Trace-Util/Makefile.PL
new file mode 100644
index 00000000000..decdeb0f678
--- /dev/null
+++ b/tools/perf/scripts/perl/Perf-Trace-Util/Makefile.PL
@@ -0,0 +1,17 @@
+use 5.010000;
+use ExtUtils::MakeMaker;
+# See lib/ExtUtils/MakeMaker.pm for details of how to influence
+# the contents of the Makefile that is written.
+WriteMakefile(
+ NAME => 'Perf::Trace::Context',
+ VERSION_FROM => 'lib/Perf/Trace/Context.pm', # finds $VERSION
+ PREREQ_PM => {}, # e.g., Module::Name => 1.1
+ ($] >= 5.005 ? ## Add these new keywords supported since 5.005
+ (ABSTRACT_FROM => 'lib/Perf/Trace/Context.pm', # retrieve abstract from module
+ AUTHOR => 'Tom Zanussi <tzanussi@gmail.com>') : ()),
+ LIBS => [''], # e.g., '-lm'
+ DEFINE => '-I ../..', # e.g., '-DHAVE_SOMETHING'
+ INC => '-I.', # e.g., '-I. -I/usr/include/other'
+ # Un-comment this if you add C files to link with later:
+ OBJECT => 'Context.o', # link all the C files too
+);