aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 82a82b90..7e87bf9c 100644
--- a/configure.in
+++ b/configure.in
@@ -285,7 +285,8 @@ if test "$ac_cv_enable_oniguruma" = yes; then
AC_MSG_CHECKING([whether Oniguruma is available])
dnl AC_CHECK_PROG(ONIG_CONFIG, onig-config, onig-config)
ONIG_CONFIG=onig-config
- if $ONIG_CONFIG --version; then
+ ONIG_VERSION=`$ONIG_CONFIG --version 2>/dev/null`
+ if test "x$ONIG_VERSION" != "x"; then
AC_MSG_RESULT(yes)
CFLAGS="$CFLAGS `$ONIG_CONFIG --cflags`"
LIBS="$LIBS `$ONIG_CONFIG --libs`"