aboutsummaryrefslogtreecommitdiff
path: root/libsylph/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libsylph/Makefile.am')
-rw-r--r--libsylph/Makefile.am21
1 files changed, 20 insertions, 1 deletions
diff --git a/libsylph/Makefile.am b/libsylph/Makefile.am
index c0cfc8f8..31771946 100644
--- a/libsylph/Makefile.am
+++ b/libsylph/Makefile.am
@@ -1,5 +1,7 @@
-AM_CPPFLAGS = -DG_LOG_DOMAIN=\"LibSylph\"
+AM_CPPFLAGS = \
+ -DG_LOG_DOMAIN=\"LibSylph\" \
+ -DSYSCONFDIR=\""$(sysconfdir)"\"
INCLUDES = $(GLIB_CFLAGS) -I$(top_srcdir) -I$(includedir)
@@ -8,13 +10,30 @@ noinst_LTLIBRARIES = libsylph.la
libsylph_la_SOURCES = \
defs.h \
+ enums.h \
+ account.c account.h \
base64.c base64.h \
codeconv.c codeconv.h \
+ customheader.c customheader.h \
+ filter.c filter.h \
+ folder.c folder.h \
html.c html.h \
+ imap.c imap.h \
+ md5.c md5.h \
+ mh.c mh.h \
+ news.c news.h \
+ nntp.c nntp.h \
+ pop.c pop.h \
prefs.c prefs.h \
+ prefs_account.c prefs_account.h \
+ prefs_common.c prefs_common.h \
+ procheader.c procheader.h \
+ procmime.c procmime.h \
+ procmsg.c procmsg.h \
quoted-printable.c quoted-printable.h \
recv.c recv.h \
session.c session.h \
+ smtp.c smtp.h \
socket.c socket.h \
ssl.c ssl.h \
stringtable.c stringtable.h \