aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build14
1 files changed, 9 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index b49e183e..61818a11 100644
--- a/meson.build
+++ b/meson.build
@@ -104,14 +104,17 @@ version_data.set('MAJOR_VERSION', '3')
version_data.set('MINOR_VERSION', '7')
version_data.set('MICRO_VERSION', '0')
version_data.set('EXTRA_VERSION', '')
-version_data.set('BUILD_REVISION', '')
version_data.set('PACKAGE', 'sylpheed')
version_data.set('VERSION', '3.7.0')
-configure_file(input : 'src/version.h.in',
- output : 'version.h',
- configuration : version_data)
+version_h_tmp = configure_file(input : 'src/version.h.in',
+ output : 'version.h.tmp',
+ configuration : version_data)
+version_h = vcs_tag(output : 'version.h',
+ input : version_h_tmp,
+ replace_string : 'VCS_TAG',
+ command: ['git', 'rev-parse', '--short', 'HEAD'])
# Instructions for building libsylph
@@ -326,7 +329,8 @@ executable('sylpheed',
'src/trayicon.c',
'src/undo.c',
'src/update_check.c',
- 'src/vcard.c'],
+ 'src/vcard.c',
+ version_h],
dependencies : [gtk, glib, gobject, gmodule, libsylph_dep, openssl,
gtkspell, aspell, enchant],
install : true)