aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build20
1 files changed, 20 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 49261a39..f34ff71c 100644
--- a/meson.build
+++ b/meson.build
@@ -165,6 +165,24 @@ quote_fmt_c = custom_target('quote_fmt.c',
'-P', 'quote_fmt',
'@INPUT@'])
+glibgenmarshal = find_program('glib-genmarshal')
+
+plugin_marshal_c = custom_target('plugin-marshal.c',
+ output : ['plugin-marshal.c'],
+ input : 'src/plugin-marshal.list',
+ command : [glibgenmarshal, '--output=@OUTPUT@',
+ '--body',
+ '--prefix=syl_plugin_marshal',
+ '@INPUT@'])
+
+plugin_marshal_h = custom_target('plugin-marshal.h',
+ output : ['plugin-marshal.h'],
+ input : 'src/plugin-marshal.list',
+ command : [glibgenmarshal, '--output=@OUTPUT@',
+ '--header',
+ '--prefix=syl_plugin_marshal',
+ '@INPUT@'])
+
executable('sylpheed',
['src/about.c',
'src/account_dialog.c',
@@ -217,6 +235,8 @@ executable('sylpheed',
'src/passphrase.c',
'src/plugin.c',
'src/plugin_manager.c',
+ plugin_marshal_c,
+ plugin_marshal_h,
'src/prefs_account_dialog.c',
'src/prefs_actions.c',
'src/prefs_common_dialog.c',