aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 6 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index dac174e9..9103ada4 100644
--- a/meson.build
+++ b/meson.build
@@ -135,10 +135,12 @@ libsylph_dep = declare_dependency(include_directories : libsylph_includes,
flex = find_program('flex')
-quote_fmt_lex_c = custom_target('quote_fmt_lex',
- output : 'quote_fmt_lex.c',
- input : 'src/quote_fmt_lex.l',
- command : [flex, '-o', '@OUTPUT@', '@INPUT@'])
+lgen = generator(flex, output : ['@BASENAME@.c', '@BASENAME@.h'],
+ arguments : ['-o', '@OUTPUT0@',
+ '--header-file=@OUTPUT1@',
+ '@INPUT@'])
+
+quote_fmt_lex_c = lgen.process('src/quote_fmt_lex.l')
executable('sylpheed',
['src/about.c',