aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas White <taw@bitwiz.me.uk>2019-02-05 08:43:09 +0100
committerThomas White <taw@bitwiz.me.uk>2019-02-05 08:43:09 +0100
commit249baac36e5d9b74a4bd435b665221652b267f81 (patch)
tree2aa668c420da71c0a9038e891b8937eb7294c1af /meson.build
parentc41fa6a9efb39e4fd0a964b7a83000647e4d32bf (diff)
WIP
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build27
1 files changed, 27 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 52b9243..a102fe4 100644
--- a/meson.build
+++ b/meson.build
@@ -27,6 +27,33 @@ gresources = gnome.compile_resources('colloquium-resources',
'data/colloquium.gresource.xml',
source_dir: 'data', c_name: 'colloquium')
+flex = find_program('flex')
+bison = find_program('bison')
+
+sc_parse_tab_ch = custom_target('sc_parse.tab.c',
+ output : ['sc_parse.tab.c',
+ 'sc_parse.tab.h'],
+ input : 'src/sc_parse.y',
+ command : [bison, '--defines=@OUTPUT1@',
+ '-p', 'sc',
+ '--output=@OUTPUT0@',
+ '@INPUT@'])
+
+sc_parse_c = custom_target('sc_parse.c',
+ output : ['sc_parse.c', 'sc_parse.h'],
+ input : ['src/sc_lex.l', sc_parse_tab_ch],
+ command : [flex, '--outfile=@OUTPUT0@',
+ '--header-file=@OUTPUT1@',
+ '-P', 'sc',
+ '@INPUT@'])
+
+executable('sc2_test',
+ ['src/sc2_test.c',
+ sc_parse_c,
+ ],
+ gresources,
+ dependencies : [gtkdep])
+
# Main program
executable('colloquium',
['src/colloquium.c',