aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas White <taw@bitwiz.me.uk>2019-02-26 22:41:41 +0100
committerThomas White <taw@bitwiz.me.uk>2019-02-26 22:41:41 +0100
commit269526b1b6aeadb57033ab0e02d20b900d71a690 (patch)
treef0552417fcbe95cb8551df92b95ff7095d346434 /meson.build
parent5f7ce131cfe4fee8d8b3427fd1f7adb58ddff68f (diff)
Skeleton GtkNarrativeView
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build25
1 files changed, 11 insertions, 14 deletions
diff --git a/meson.build b/meson.build
index a7d517e..6badf9d 100644
--- a/meson.build
+++ b/meson.build
@@ -83,19 +83,16 @@ libstorycode_dep = declare_dependency(include_directories : libstorycode_include
# libstorycode-gtk
-#libstorycode_gtk_includes = include_directories('libstorycode/gtk')
-#
-#libstorycode_gtk = library('storycode-gtk',
-# ['libstorycode/gtk/gtknarrativeview.c',
-# 'libstorycode/gtk/gtkslideview.c',
-# ],
-# include_directories : libstorycode_gtk_includes,
-# dependencies : [gtk_dep, libstorycode_dep,
-# libstorycode_cairo_dep],
-# install : true)
-#
-#libstorycode_gtk_dep = declare_dependency(include_directories : libstorycode_gtk_includes,
-# link_with : libstorycode_gtk)
+libgtkstorycode_includes = include_directories('libstorycode/gtk')
+
+libgtkstorycode = library('storycode-gtk',
+ ['libstorycode/gtk/gtknarrativeview.c'],
+ include_directories : libgtkstorycode_includes,
+ dependencies : [gtk_dep, libstorycode_dep],
+ install : true)
+
+libgtkstorycode_dep = declare_dependency(include_directories : libgtkstorycode_includes,
+ link_with : libgtkstorycode)
# pdfstorycode
@@ -118,7 +115,7 @@ executable('colloquium',
# 'src/stylesheet_editor.c',
],
gresources,
- dependencies : [gtk_dep, mdep, libstorycode_dep],
+ dependencies : [gtk_dep, mdep, libstorycode_dep, libgtkstorycode_dep],
install : true)