aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas White <taw@bitwiz.me.uk>2019-02-22 22:20:10 +0100
committerThomas White <taw@bitwiz.me.uk>2019-02-22 22:20:10 +0100
commitaee387068f5b9013687250e8d655b56a0c5776f2 (patch)
treeb835c6a32dc1731a3a1634564fee82851e26790d /meson.build
parent3ff425d840876c0db965b23826998161ee87c1fd (diff)
Rearrange rendering stuff
Rendering parts are allowed to access the internals of the slide structure, to avoid a profusion of getter/setter functions.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build22
1 files changed, 4 insertions, 18 deletions
diff --git a/meson.build b/meson.build
index 420c5b1..2f05a81 100644
--- a/meson.build
+++ b/meson.build
@@ -63,32 +63,19 @@ libstorycode = library('storycode',
'libstorycode/presentation.c',
'libstorycode/stylesheet.c',
'libstorycode/storycode.c',
+ 'libstorycode/slide_render_cairo.c',
storycode_lex_ch,
storycode_parse_ch,
],
include_directories : libstorycode_includes,
+ dependencies : [cairo_dep, pango_dep, gdkpixbuf_dep,
+ pangocairo_dep],
install : true)
libstorycode_dep = declare_dependency(include_directories : libstorycode_includes,
link_with : libstorycode)
-# libstorycode-cairo
-libstorycode_cairo_includes = include_directories('libstorycode/cairo')
-
-libstorycode_cairo = library('storycode-cairo',
- ['libstorycode/cairo/render.c',
- ],
- include_directories : libstorycode_cairo_includes,
- dependencies : [cairo_dep, pango_dep, gdkpixbuf_dep,
- pangocairo_dep,
- libstorycode_dep],
- install : true)
-
-libstorycode_cairo_dep = declare_dependency(include_directories : libstorycode_cairo_includes,
- link_with : libstorycode_cairo)
-
-
# libstorycode-gtk
#libstorycode_gtk_includes = include_directories('libstorycode/gtk')
#
@@ -111,8 +98,7 @@ executable('pdfstorycode',
],
gresources,
dependencies : [glib_dep, gio_dep, cairo_dep, pango_dep,
- pangocairo_dep,
- libstorycode_dep, libstorycode_cairo_dep])
+ pangocairo_dep, libstorycode_dep])
# Main program