aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2019-02-14 20:05:55 +0100
committerThomas White <taw@physics.org>2019-02-14 20:05:55 +0100
commitcd63ea1509bc349ce3b0042da134da7c193213d5 (patch)
treefe9a0e9282963f9af04356a63b08826a36155d16 /meson.build
parented54079dcd5ae5d6b801b9a0ea2f3ba013c08c0d (diff)
Fussiness
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 4 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 2dc827d..c99fb01 100644
--- a/meson.build
+++ b/meson.build
@@ -42,13 +42,13 @@ flex_gen = generator(flex,
bison_gen = generator(bison,
output : ['@BASENAME@_parse.c', '@BASENAME@_parse.h'],
- arguments : ['--defines=@OUTPUT1@',
+ arguments : ['--output=@OUTPUT0@',
+ '--defines=@OUTPUT1@',
'--report=all',
- '--output=@OUTPUT0@',
'@INPUT@'])
-storycode_lex_c = flex_gen.process('libstorycode/storycode.l')
storycode_parse_ch = bison_gen.process('libstorycode/storycode.y')
+storycode_lex_ch = flex_gen.process('libstorycode/storycode.l')
libstorycode = library('storycode',
['libstorycode/narrative.c',
@@ -56,7 +56,7 @@ libstorycode = library('storycode',
'libstorycode/presentation.c',
'libstorycode/stylesheet.c',
'libstorycode/storycode.c',
- storycode_lex_c,
+ storycode_lex_ch,
storycode_parse_ch,
],
include_directories : libstorycode_includes,