summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2019-09-24 10:38:07 +0200
committerThomas White <taw@physics.org>2019-09-24 10:38:07 +0200
commitef821b9bc294efc17272cd94ed1b05c2b6831a73 (patch)
tree6031f14fbd2b64462754d3a161ec7fb3ee1a9071 /meson.build
Skeleton GTK3 program
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/meson.build b/meson.build
new file mode 100644
index 0000000..6e26846
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,11 @@
+project('crystfel-demo', 'c',
+ version : '0.1.0',
+ license : 'GPL3+',
+ default_options : ['buildtype=debugoptimized'])
+
+gtk_dep = dependency('gtk+-3.0', required : true)
+
+executable('crystfel-demo',
+ ['crystfel-demo.c',
+ ],
+ dependencies : [gtk_dep])