aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2018-03-21 16:54:46 +0100
committerThomas White <taw@physics.org>2018-03-21 17:01:13 +0100
commit53755d93445d7cfc49362f5c5c6dfa1770332ba2 (patch)
treed3eaf9a6b88f0d67ceb495f969f15a26655091c8 /CMakeLists.txt
parent018bff49cd1f5fbd3071b092d0546be67147e893 (diff)
Remove BUILD_EXPLORER and BUILD_HDFSEE options
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 4 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3db2ab58..eecfd882 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3,9 +3,6 @@ project(crystfel)
include(GNUInstallDirs)
-option(BUILD_HDFSEE "Build hdfsee" ON)
-option(BUILD_EXPLORER "Build the cell_explorer" ON)
-
# Set CMAKE_MODULE_PATH to assist cmake in finding our own package definitions
set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/CMake")
@@ -136,7 +133,7 @@ set_target_properties(pattern_sim PROPERTIES
# Build Target
# hdfsee
-if(BUILD_HDFSEE AND GTK2_FOUND AND TIFF_FOUND)
+if(GTK2_FOUND AND TIFF_FOUND)
set(HDFSEE_SOURCES
src/hdfsee.c
@@ -172,13 +169,13 @@ if(BUILD_HDFSEE AND GTK2_FOUND AND TIFF_FOUND)
RESOURCE DESTINATION share/crystfel
)
-endif(BUILD_HDFSEE AND GTK2_FOUND AND TIFF_FOUND)
+endif(GTK2_FOUND AND TIFF_FOUND)
# ----------------------------------------------------------------------
# Build Target
# cell_explorer
-if(BUILD_EXPLORER AND GTK2_FOUND)
+if (GTK2_FOUND)
set(CELL_EXPLORER_SOURCES
src/cell_explorer.c
@@ -197,7 +194,7 @@ if(BUILD_EXPLORER AND GTK2_FOUND)
LIBRARY DESTINATION lib
)
-endif(BUILD_EXPLORER AND GTK2_FOUND)
+endif(GTK2_FOUND)
# ----------------------------------------------------------------------
# Build Target