aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2018-03-28 11:06:30 +0200
committerThomas White <taw@physics.org>2018-03-28 11:38:48 +0200
commit665888986b9a3ca629b8fd54965d621296bd56bb (patch)
tree4b9b26857fdaeaa6c7c60d5491ba8664edf49241 /CMakeLists.txt
parent5c8489859d9c3d6a071ad5817d669694a811553d (diff)
Add gtk-doc stuff
This is really horrible and doesn't work 100%. Replace with something else ASAP
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ce7a6e26..773d246e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -87,6 +87,19 @@ add_subdirectory(libcrystfel)
enable_testing()
add_subdirectory(tests)
+# API docs
+find_package(GtkDoc 1.25)
+if (GTKDOC_FOUND)
+ configure_file(doc/reference/libcrystfel/xml/gtkdocentities.ent.cmake.in
+ docs/xml/gtkdocentities.ent)
+ configure_file(doc/reference/libcrystfel/CrystFEL-docs.sgml
+ docs/CrystFEL-docs.sgml COPYONLY)
+ add_custom_target(documentation VERBATIM COMMAND
+ ${CMAKE_SOURCE_DIR}/doc/reference/libcrystfel/build-docs)
+ install(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/docs/html
+ DESTINATION ${CMAKE_INSTALL_DOCDIR})
+endif (GTKDOC_FOUND)
+
# ----------------------------------------------------------------------
# Build Target
# partial_sim