aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2018-03-22 15:04:33 +0100
committerThomas White <taw@physics.org>2018-03-22 15:32:02 +0100
commitbd5254b087bf38da5bd1aead7e32af508c0b12b4 (patch)
tree959a0d69bf020c1b8bdcde24e79540894c555fda /CMakeLists.txt
parent4a244ff26c30c5500615b81acacab9d2080fcd11 (diff)
Compile and run tests
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f6546cb2..07ba6d4b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -80,6 +80,10 @@ include_directories(${CMAKE_CURRENT_BINARY_DIR})
# Add the libcrystfel target
add_subdirectory(libcrystfel)
+# Add tests
+enable_testing()
+add_subdirectory(tests)
+
# ----------------------------------------------------------------------
# Build Target
# partial_sim