aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2018-03-22 11:02:20 +0100
committerThomas White <taw@physics.org>2018-03-22 11:02:20 +0100
commitce04a3404f0e949db72692eb55c5c97485d2d05a (patch)
tree5ee62459734095a1f1d1f9d3c5c42c05b4f32a2c /CMakeLists.txt
parentf825769ab8fd476eea207c6c061294aaf97b5744 (diff)
render_hkl doesn't need GTK
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt31
1 files changed, 9 insertions, 22 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2ad2c0d1..a36dc14f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -185,32 +185,19 @@ endif(GTK2_FOUND)
# Build Target
# render_hkl
-if(CAIRO_FOUND AND GTK2_FOUND)
+if (CAIRO_FOUND)
- set(RENDER_HKL_SOURCES
- src/render_hkl.c
- )
+ set(RENDER_HKL_SOURCES src/render_hkl.c)
+ add_executable(render_hkl ${RENDER_HKL_SOURCES})
- add_executable(render_hkl ${RENDER_HKL_SOURCES})
- target_include_directories(render_hkl PRIVATE
- ${COMMON_INCLUDES}
- ${GTK2_INCLUDE_DIRS}
- ${CAIRO_INCLUDE_DIRS}
- )
- target_link_libraries(render_hkl
- ${COMMON_LIBRARIES}
- ${GTK2_LIBRARIES}
- ${CAIRO_LIBRARIES}
- )
+ target_include_directories(render_hkl PRIVATE ${COMMON_INCLUDES} ${CAIRO_INCLUDE_DIRS})
+ target_link_libraries(render_hkl ${COMMON_LIBRARIES} ${CAIRO_LIBRARIES})
- install(
- TARGETS
- render_hkl
+ install (TARGETS render_hkl
+ RUNTIME DESTINATION bin
+ LIBRARY DESTINATION lib)
- RUNTIME DESTINATION bin
- LIBRARY DESTINATION lib
- )
-endif(CAIRO_FOUND AND GTK2_FOUND)
+endif (CAIRO_FOUND)
# ----------------------------------------------------------------------
# Build Target