aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2014-02-28 11:36:55 +0100
committerThomas White <taw@physics.org>2014-02-28 11:36:55 +0100
commit627590fc42d18e44795c47f2968f298318c5038a (patch)
tree53624dd5f7f090479530f1cec827f4e292194acd /Makefile.am
parent16c27cc308b624159d0cc9f334e97797e1b854ae (diff)
Introduce cell_explorer
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index f117d67d..cbf76cb4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -34,6 +34,10 @@ if BUILD_HDFSEE
bin_PROGRAMS += src/hdfsee
endif
+if BUILD_EXPLORER
+bin_PROGRAMS += src/cell_explorer
+endif
+
if HAVE_CAIRO
bin_PROGRAMS += src/render_hkl
endif
@@ -64,6 +68,10 @@ if BUILD_HDFSEE
src_hdfsee_SOURCES = src/hdfsee.c src/dw-hdfsee.c src/hdfsee-render.c
endif
+if BUILD_EXPLORER
+src_cell_explorer_SOURCES = src/cell_explorer.c src/multihistogram.c
+endif
+
src_get_hkl_SOURCES = src/get_hkl.c
src_compare_hkl_SOURCES = src/compare_hkl.c
@@ -116,7 +124,7 @@ EXTRA_DIST += src/dw-hdfsee.h src/hdfsee.h src/render_hkl.h \
src/post-refinement.h src/hrs-scaling.h src/scaling-report.h \
src/cl-utils.h src/hdfsee-render.h src/diffraction.h \
src/diffraction-gpu.h src/pattern_sim.h src/list_tmp.h \
- src/im-sandbox.h src/process_image.h
+ src/im-sandbox.h src/process_image.h src/multihistogram.h
crystfeldir = $(datadir)/crystfel
crystfel_DATA = data/diffraction.cl data/hdfsee.ui