aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas White <taw@bitwiz.org.uk>2012-01-19 17:18:16 -0800
committerThomas White <taw@physics.org>2012-02-22 15:27:43 +0100
commit6c5ecd972440e2a3ba9947c8f480dd03af039089 (patch)
tree4054c33f30bb8268c9d8460d49340b4d12044b18 /configure.ac
parent694ff56d0632214a5e4d6df0849e6b1a48aa43bd (diff)
Make the use of Pango optional
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e9384f1e..05d4f15d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -191,6 +191,24 @@ AS_IF([test "x$enable_cairo" != "xno"],
])
+AC_MSG_CHECKING([whether to use Pango])
+AC_ARG_ENABLE([pango],
+ AS_HELP_STRING([--disable-pango], [Disable the use of Pango]))
+AS_IF([test "x$enable_pango" != "xno"],
+[
+ AC_MSG_RESULT([yes])
+ PKG_CHECK_MODULES([Pango], [pango >= 1.0.0],
+ [
+ have_pango=true
+ AC_DEFINE([HAVE_PANGO], [1], [Define to 1 if Pango is available])
+ ], [
+ have_pango=false
+ ])
+], [
+ AC_MSG_RESULT([no])
+])
+
+
AC_MSG_CHECKING([whether to use GDK-pixbuf])
AC_ARG_ENABLE([gdk-pixbuf], AS_HELP_STRING([--disable-gdk-pixbuf],
[Disable the use of gtk-pixbuf]))
@@ -248,6 +266,8 @@ AM_CONDITIONAL([BUILD_HDFSEE], test x$have_gdk_pixbuf = xtrue \
AM_CONDITIONAL([HAVE_CAIRO], test x$have_cairo = xtrue)
+AM_CONDITIONAL([HAVE_PANGO], test x$have_pango = xtrue)
+
AM_CONDITIONAL([HAVE_FFTW], test x$have_fftw = xtrue)
gl_IGNORE_UNUSED_LIBRARIES