aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2011-03-22 11:16:47 +0100
committerThomas White <taw@physics.org>2012-02-22 15:27:20 +0100
commiteaee0f6415b06f40ff7f477328f9f26f01c4d7ec (patch)
treea80d312a18dfdcee1716610c8faa6048a5a32ac8 /configure.ac
parent5b903bf7bbef684dbbaf27073a7a7e452e27a23f (diff)
Add thread affinity stuff
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e89dd096..f7cbe188 100644
--- a/configure.ac
+++ b/configure.ac
@@ -213,6 +213,12 @@ AS_IF([test "x$enable_gdk_pixbuf" != "xno"],
])
+AC_CHECK_LIB([pthread], [sched_setaffinity], [
+ AC_DEFINE([HAVE_CPU_AFFINITY], [1],
+ [Define to 1 if sched_setaffinity is available.])
+])
+
+
dnl Conditionals...
AM_CONDITIONAL([HAVE_OPENCL], test x$have_opencl = xtrue)