aboutsummaryrefslogtreecommitdiff
path: root/libcrystfel/CMakeLists.txt
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2021-09-29 16:47:48 +0200
committerThomas White <taw@physics.org>2021-09-29 16:47:48 +0200
commit151629cd57e7047683bfce48b393f6e21da9b90d (patch)
treee0019c35761cfe0687675d3b1125bd776a46d294 /libcrystfel/CMakeLists.txt
parent9438abb00b495f28c5b2c306fe4d391f6a44acc9 (diff)
Fix Doxygen version numbers
This also removes Doxygen from the CMake build system. It doesn't seem worth trying to make it work both ways. Fixes: https://gitlab.desy.de/thomas.white/crystfel/-/issues/48
Diffstat (limited to 'libcrystfel/CMakeLists.txt')
-rw-r--r--libcrystfel/CMakeLists.txt11
1 files changed, 0 insertions, 11 deletions
diff --git a/libcrystfel/CMakeLists.txt b/libcrystfel/CMakeLists.txt
index 77290677..83f1e983 100644
--- a/libcrystfel/CMakeLists.txt
+++ b/libcrystfel/CMakeLists.txt
@@ -8,7 +8,6 @@ find_package(ZLIB REQUIRED)
find_package(FLEX REQUIRED)
find_package(BISON REQUIRED)
pkg_check_modules(MSGPACK msgpack)
-find_package(Doxygen)
pkg_check_modules(FFTW fftw3)
pkg_check_modules(LIBCCP4 libccp4c)
@@ -103,16 +102,6 @@ set(LIBCRYSTFEL_HEADERS
src/fom.h
)
-if (DOXYGEN_FOUND)
- configure_file(${PROJECT_SOURCE_DIR}/doc/index.md index.md)
- set(DOXYGEN_SHOW_INCLUDE_FILES NO)
- set(DOXYGEN_WARN_IF_UNDOCUMENTED NO)
- set(DOXYGEN_PREDEFINED HAVE_FFTW)
- doxygen_add_docs(api-docs ${PROJECT_SOURCE_DIR}/src
- ${CMAKE_CURRENT_BINARY_DIR}/index.md
- ${PROJECT_SOURCE_DIR}/doc/coding.md)
-endif (DOXYGEN_FOUND)
-
add_library(${PROJECT_NAME} SHARED
${LIBCRYSTFEL_SOURCES}
${CMAKE_CURRENT_BINARY_DIR}/libcrystfel-version.c