aboutsummaryrefslogtreecommitdiff
path: root/libcrystfel/CMakeLists.txt
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2020-03-17 12:12:01 +0100
committerThomas White <taw@physics.org>2020-07-29 18:42:57 +0200
commit3972e0d898a73374838d9ea5b69570757f4b161c (patch)
tree3c59bf4ce9cdf1740f284a926e4d3c94e968b834 /libcrystfel/CMakeLists.txt
parent14dd1029b41e5b50428160a56d025b0e56141f94 (diff)
Actually run indexamajig
Diffstat (limited to 'libcrystfel/CMakeLists.txt')
-rw-r--r--libcrystfel/CMakeLists.txt13
1 files changed, 0 insertions, 13 deletions
diff --git a/libcrystfel/CMakeLists.txt b/libcrystfel/CMakeLists.txt
index 1e30bf81..06e7dfa3 100644
--- a/libcrystfel/CMakeLists.txt
+++ b/libcrystfel/CMakeLists.txt
@@ -21,19 +21,6 @@ set(CMAKE_REQUIRED_LIBRARIES "-lz")
check_symbol_exists(gzbuffer "zlib.h" HAVE_GZBUFFER)
unset(CMAKE_REQUIRED_LIBRARIES)
-# Find out where forkpty() is declared
-set(CMAKE_REQUIRED_LIBRARIES "-lutil")
-check_symbol_exists(forkpty "pty.h" HAVE_FORKPTY_PTY_H)
-check_symbol_exists(forkpty "util.h" HAVE_FORKPTY_UTIL_H)
-unset(CMAKE_REQUIRED_LIBRARIES)
-if(HAVE_FORKPTY_PTY_H)
- message(STATUS "Found forkpty() in pty.h")
-elseif(HAVE_FORKPTY_UTIL_H)
- message(STATUS "Found forkpty() in util.h")
-else()
- message(SEND_ERROR "Couldn't find forkpty()")
-endif()
-
configure_file(config.h.cmake.in config.h)
bison_target(symopp src/symop.y ${CMAKE_CURRENT_BINARY_DIR}/symop-parse.c COMPILE_FLAGS --report=all)