aboutsummaryrefslogtreecommitdiff
path: root/libcrystfel/CMakeLists.txt
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2022-04-29 16:53:49 +0200
committerThomas White <taw@physics.org>2022-05-04 14:47:35 +0200
commit3fb81ddf7059599dba9b8b223156801af6885fc1 (patch)
tree23fb95dbf4279c164b5f564082fb4b9b40e5bbf2 /libcrystfel/CMakeLists.txt
parentcdb51dbec109ccde45c8a4ceb29ea925d01e2920 (diff)
Add improved profiling
Improvements: - Recursive, so we can see how things are working at different levels - Everything is profiled, even if not explicitly labelled - No possibility of losing time - Detects mistakes if routines aren't wrapped correctly
Diffstat (limited to 'libcrystfel/CMakeLists.txt')
-rw-r--r--libcrystfel/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/libcrystfel/CMakeLists.txt b/libcrystfel/CMakeLists.txt
index 69668a8c..3ca50b1f 100644
--- a/libcrystfel/CMakeLists.txt
+++ b/libcrystfel/CMakeLists.txt
@@ -62,6 +62,7 @@ set(LIBCRYSTFEL_SOURCES
src/image-hdf5.c
src/fom.c
src/image-msgpack.c
+ src/profile.c
${BISON_symopp_OUTPUTS}
${FLEX_symopl_OUTPUTS}
src/indexers/dirax.c
@@ -99,6 +100,7 @@ set(LIBCRYSTFEL_HEADERS
src/colscale.h
src/detgeom.h
src/fom.h
+ src/profile.h
)
add_library(${PROJECT_NAME} SHARED