aboutsummaryrefslogtreecommitdiff
path: root/libcrystfel/CMakeLists.txt
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2019-01-29 10:58:18 +0100
committerThomas White <taw@physics.org>2019-01-29 10:58:18 +0100
commit4f4e5d05269eee6b192c271f2f9730a1ad3a4fbd (patch)
tree3cc6b779c70ddf6ac52615ab7ef7ef26575a645f /libcrystfel/CMakeLists.txt
parent6d68881f043921b3a859c5bff71d171ab4a7096b (diff)
Strip out CPU affinity stuff
This was from an early experiment when we were having performance problems on a big NUMA machine. It didn't help very much back then, and it certainly doesn't help much now. It's not worth maintaining the code or build system needed for this.
Diffstat (limited to 'libcrystfel/CMakeLists.txt')
-rw-r--r--libcrystfel/CMakeLists.txt5
1 files changed, 0 insertions, 5 deletions
diff --git a/libcrystfel/CMakeLists.txt b/libcrystfel/CMakeLists.txt
index 70d9c198..d17f7913 100644
--- a/libcrystfel/CMakeLists.txt
+++ b/libcrystfel/CMakeLists.txt
@@ -15,11 +15,6 @@ set(HAVE_XGANDALF ${XGANDALF_FOUND})
set(HAVE_FDIP ${FDIP_FOUND})
set(HAVE_CBFLIB ${CBF_FOUND})
-# Check for CPU affinity functions (Linux-specific)
-set(CMAKE_REQUIRED_DEFINITIONS "-D_GNU_SOURCE")
-check_symbol_exists(sched_setaffinity "sched.h" HAVE_CPU_AFFINITY)
-unset(CMAKE_REQUIRED_DEFINITIONS)
-
# Find out where forkpty() is declared
set(CMAKE_REQUIRED_LIBRARIES "-lutil")
check_symbol_exists(forkpty "pty.h" HAVE_FORKPTY_PTY_H)