aboutsummaryrefslogtreecommitdiff
path: root/libcrystfel/CMakeLists.txt
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2020-06-08 14:16:51 +0200
committerThomas White <taw@physics.org>2020-07-29 18:53:44 +0200
commit9aac978cbe89adc784aeb049f80bb465b80dfbc0 (patch)
tree140ba0023b7692c78147c121f20d95c066029640 /libcrystfel/CMakeLists.txt
parentdff86d3c650e0b117a10be9d2c2c6f788b97629e (diff)
Move MessagePack stuff to separate file
Note the nicer separation: ZMQ is in indexamajig only, whereas MessagePack becomes something generally accessible through libcrystfel.
Diffstat (limited to 'libcrystfel/CMakeLists.txt')
-rw-r--r--libcrystfel/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/libcrystfel/CMakeLists.txt b/libcrystfel/CMakeLists.txt
index efbac466..b3a7764c 100644
--- a/libcrystfel/CMakeLists.txt
+++ b/libcrystfel/CMakeLists.txt
@@ -65,6 +65,7 @@ set(LIBCRYSTFEL_SOURCES
src/detgeom.c
src/image-cbf.c
src/image-hdf5.c
+ src/image-msgpack.c
${BISON_symopp_OUTPUTS}
${FLEX_symopl_OUTPUTS}
)
@@ -108,6 +109,7 @@ set(LIBCRYSTFEL_HEADERS
src/datatemplate.h
src/colscale.h
src/detgeom.h
+ src/image-msgpack.h
)
if (DOXYGEN_FOUND)