aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authortaw27 <taw27@bf6ca9ba-c028-0410-8290-897cf20841d1>2007-02-05 21:12:57 +0000
committertaw27 <taw27@bf6ca9ba-c028-0410-8290-897cf20841d1>2007-02-05 21:12:57 +0000
commit05b5d261682b9136fb46476a64eab6980b0dba64 (patch)
treed7faa450b69cf2104ffff7fc89a95914284d23af /configure.ac
Initial import
git-svn-id: svn://cook.msm.cam.ac.uk:745/diff-tomo/dtr@1 bf6ca9ba-c028-0410-8290-897cf20841d1
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac42
1 files changed, 42 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..4725129
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,42 @@
+dnl Process this file with autoconf to produce a configure script.
+
+AC_INIT(dtr, 1.0.4, taw27@cam.ac.uk)
+VERSION=AC_PACKAGE_VERSION
+
+AM_CONFIG_HEADER(config.h)
+AM_INIT_AUTOMAKE(dtr, "$VERSION")
+
+AC_PROG_CC
+AC_PROG_AWK
+AC_PROG_INSTALL
+AC_PROG_LN_S
+
+AC_HEADER_STDC
+AC_CHECK_HEADERS([fcntl.h stdlib.h string.h unistd.h])
+AC_C_CONST
+AC_FUNC_MALLOC
+AC_FUNC_FORK
+AC_HEADER_SYS_WAIT
+AC_TYPE_SIGNAL
+AC_TYPE_PID_T
+AC_CHECK_FUNCS([strdup])
+AC_CHECK_FUNCS([floor])
+AC_CHECK_FUNCS([pow])
+AC_CHECK_FUNCS([rint])
+AC_CHECK_FUNCS([sqrt])
+
+AM_PATH_GTK_2_0(2.6.0,,AC_MSG_ERROR([
+*** GTK+ 2.6.0 or above is required by dtr. Please make sure you have the GTK+
+*** development files installed. The latest version of GTK+ is
+*** always available at http://www.gtk.org/.]))
+
+dnl AC_CHECK_LIB([fftw3], [fftw_execute])
+AC_CHECK_LIB(m,main)
+AC_CHECK_LIB(gsl,main)
+AC_CHECK_LIB(gslcblas,main)
+
+AM_PATH_GTKGLEXT_1_0(1.0.0,[echo "$GTKGLEXT_LIBS"],AC_MSG_ERROR([
+ *** gtkglext is required to build dtr; please make sure you have the
+ *** gtkglext development headers installed.]))
+
+AC_OUTPUT(Makefile src/Makefile data/Makefile)