aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bc76603c..a9322ed1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -70,6 +70,11 @@ AC_ARG_ENABLE(nouveau-experimental-api,
[NOUVEAU=$enableval], [NOUVEAU=no])
+AC_ARG_ENABLE(glamo-experimental-api,
+ AS_HELP_STRING([--enable-glamo-experimental-api],
+ [Enable support for Glamo's KMS API (default: disabled)]),
+ [GLAMO=$enableval], [GLAMO=no])
+
dnl ===========================================================================
dnl check compiler flags
AC_DEFUN([LIBDRM_CC_TRY_FLAG], [
@@ -166,6 +171,8 @@ if test "x$NOUVEAU" = xyes; then
AC_DEFINE(HAVE_NOUVEAU, 1, [Have nouveau (nvidia) support])
fi
+AM_CONDITIONAL(HAVE_GLAMO, [test "x$GLAMO" = xyes])
+
PKG_CHECK_MODULES(CAIRO, cairo, [HAVE_CAIRO=yes], [HAVE_CAIRO=no])
if test "x$HAVE_CAIRO" = xyes; then
AC_DEFINE(HAVE_CAIRO, 1, [Have cairo support])
@@ -259,6 +266,8 @@ AC_OUTPUT([
radeon/libdrm_radeon.pc
nouveau/Makefile
nouveau/libdrm_nouveau.pc
+ glamo/Makefile
+ glamo/libdrm_glamo.pc
tests/Makefile
tests/modeprint/Makefile
tests/modetest/Makefile