summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index cc588d5fab..f9476a46dd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1190,6 +1190,19 @@ AC_ARG_WITH([max-height],
)
dnl
+dnl Gallium SVGA configuration
+dnl
+AC_ARG_ENABLE([gallium-svga],
+ [AS_HELP_STRING([--disable-gallium-svga],
+ [build gallium SVGA @<:@default=enabled@:>@])],
+ [enable_gallium_svga="$enableval"],
+ [enable_gallium_svga=yes])
+if test "x$enable_gallium_svga" = xyes; then
+ GALLIUM_WINSYS_DRM_DIRS="$GALLIUM_WINSYS_DRM_DIRS vmware"
+ GALLIUM_DRIVERS_DIRS="$GALLIUM_DRIVERS_DIRS svga"
+fi
+
+dnl
dnl Gallium Intel configuration
dnl
AC_ARG_ENABLE([gallium-intel],