summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2019-05-24 20:51:46 +0200
committerThomas White <taw@physics.org>2019-05-24 20:51:46 +0200
commit9d4d46b2c8264de1eb33ad96a2acb1e52020ae22 (patch)
tree7e628e39edf1cad1348bc6c070687edf9675225d /meson.build
Initial skeleton import
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build29
1 files changed, 29 insertions, 0 deletions
diff --git a/meson.build b/meson.build
new file mode 100644
index 0000000..d939dac
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,29 @@
+# Meson file for NanoLight
+project('nanolight', 'c',
+ version : '0.1.0',
+ license : 'GPL3+',
+ default_options : ['buildtype=debugoptimized'])
+
+# Localisation
+subdir('po')
+add_project_arguments('-DLOCALEDIR="'+join_paths(get_option('prefix'), get_option('localedir'))+'"',
+ language : 'c')
+
+# Dependencies
+gnome = import('gnome')
+gdk_dep = dependency('gdk-3.0', required : true)
+gtk_dep = dependency('gtk+-3.0', required : true)
+glib_dep = dependency('glib-2.0', required : true)
+gio_dep = dependency('gio-2.0', required : true)
+cairo_dep = dependency('cairo', required : true)
+pango_dep = dependency('pango', required : true)
+pangocairo_dep = dependency('pangocairo', required : true)
+cc = meson.get_compiler('c')
+mdep = cc.find_library('m', required : false)
+
+# Main program
+executable('nanolight',
+ ['src/nanolight.c',
+ ],
+ dependencies : [gtk_dep, mdep],
+ install : true)