aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas White <taw@bitwiz.org.uk>2009-07-19 23:25:26 +0100
committerThomas White <taw@bitwiz.org.uk>2009-07-19 23:25:26 +0100
commit1f734762998ff92dff6173e877ece014a288b7b5 (patch)
tree342a418c593e3dd634af0b3ecf88b9b538488064 /configure.ac
parentc324c1f0bc2974d154a2dd2ff1472d652f3f45c2 (diff)
Use ALSA directly for audio
I'm really bored of hearing about problems with the audio in OpenMooCow, when these problems are due to SDL's audio subsystem. Problems have arised from configuration problems somewhere in the OE configuration for Openmoko, or from a strange kernel interaction seen in Debian and Fedora. With this commit, the audio module of OpenMooCow will use ALSA directly, circumventing all these problems. There should no longer be any need for fallbacks.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 12 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 712ddcd..a1898a1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -30,7 +30,7 @@ AM_PATH_GTK_2_0(2.0.0,,AC_MSG_ERROR([
*** Please make sure you have the GTK+ development files installed. The
*** latest version of GTK+ is always available at http://www.gtk.org/.]))
-AC_MSG_CHECKING([SDL])
+AC_MSG_CHECKING([for SDL])
if $PKG_CONFIG sdl ; then
LIBSDL_CFLAGS=`$PKG_CONFIG --cflags sdl`
LIBSDL_LIBS=`$PKG_CONFIG --libs sdl`
@@ -40,7 +40,16 @@ else
AC_MSG_ERROR([*** SDL not found. Do you have 'libsdl-dev' or similar installed?])
fi
-CFLAGS="$CFLAGS $GTK_CFLAGS $LIBSDL_CFLAGS"
-LIBS="$LIBS $GTK_LIBS $LIBSDL_LIBS -lgthread-2.0"
+AC_MSG_CHECKING([for ALSA])
+if $PKG_CONFIG sdl ; then
+ ALSA_CFLAGS=`$PKG_CONFIG --cflags alsa`
+ ALSA_LIBS=`$PKG_CONFIG --libs alsa`
+ AC_MSG_RESULT([yes])
+else
+ AC_MSG_RESULT([not found])
+fi
+
+CFLAGS="$CFLAGS $GTK_CFLAGS $LIBSDL_CFLAGS $ALSA_CFLAGS"
+LIBS="$LIBS $GTK_LIBS $LIBSDL_LIBS $ALSA_LIBS -lgthread-2.0"
AC_OUTPUT(Makefile src/Makefile data/Makefile)