aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2021-10-26 21:32:57 +0200
committerThomas White <taw@physics.org>2021-10-26 21:32:57 +0200
commit9146879701b0088de872656b8c2ea4f1771c2909 (patch)
treee23147d733e2a48d656f0c1c5e987b0f700de4cf /meson.build
parent6f6ba98dbe271158008e711e203e161a107378dc (diff)
Add playback display utility
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 6edbd81..b4451a9 100644
--- a/meson.build
+++ b/meson.build
@@ -43,5 +43,17 @@ executable('starlet-fixture-display',
install: true)
+# Playback display tool
+executable('starlet-playback-display',
+ ['src/starlet-playback-display.c',
+ 'src/repl-connection.c'],
+ dependencies: [gtk_dep,
+ cairo_dep,
+ pango_dep,
+ pangocairo_dep,
+ guile_dep],
+ install: true)
+
+
# Install Scheme source files (all at once)
install_subdir('guile/starlet', install_dir: guile_sitedir)