aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2021-06-09 17:58:24 +0200
committerThomas White <taw@physics.org>2021-06-19 19:49:05 +0200
commitc6c277b79711a0999d6db39a06cc3981cf3fd8a9 (patch)
treef55592b4513b1a701530d8ac4043ee6fb964cef9 /meson.build
parent49b569408adb6c2709adbd816d2a6d0e283320f2 (diff)
Skeleton fixture display tool
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build27
1 files changed, 27 insertions, 0 deletions
diff --git a/meson.build b/meson.build
new file mode 100644
index 0000000..f9ca007
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,27 @@
+# Meson file for Starlet
+project('starlet', 'c',
+ version : '0.1.0',
+ license : 'GPL3+',
+ default_options : ['buildtype=debugoptimized'])
+
+# Localisation
+subdir('po')
+add_project_arguments('-DLOCALEDIR="'+join_paths(get_option('prefix'), get_option('localedir'))+'"',
+ language : 'c')
+
+
+# Dependencies
+gnome = import('gnome')
+cc = meson.get_compiler('c')
+mdep = cc.find_library('m', required : false)
+gtk_dep = dependency('gtk+-3.0', required : true)
+cairo_dep = dependency('cairo', required : true)
+pango_dep = dependency('pango', required : true)
+pangocairo_dep = dependency('pangocairo', required : true)
+
+
+# Fixture display tool
+executable('starlet-fixture-display',
+ ['src/starlet-fixture-display.c'],
+ dependencies : [gtk_dep],
+ install : true)