aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorhiro <hiro@ee746299-78ed-0310-b773-934348b2243d>2005-10-05 08:53:48 +0000
committerhiro <hiro@ee746299-78ed-0310-b773-934348b2243d>2005-10-05 08:53:48 +0000
commit48780a7b2d4d98e310c34b5ebb6cc2c8c8723ffe (patch)
tree9124d14caa29ae6e441199dc2d53b8008b76474c /configure.in
parent0ce22afa2e2b62105ea8c6b022dbae86778cd773 (diff)
support SSL on win32.
git-svn-id: svn://sylpheed.sraoss.jp/sylpheed/trunk@621 ee746299-78ed-0310-b773-934348b2243d
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 1b5b7da7..2e66c3b0 100644
--- a/configure.in
+++ b/configure.in
@@ -53,11 +53,14 @@ AM_PROG_LIBTOOL
SYLPHEED_ACLOCAL_INCLUDE(ac)
+native_win32=no
+
case "$target" in
*-darwin*)
CFLAGS="$CFLAGS -no-cpp-precomp -fno-common"
;;
*-*-mingw*)
+ native_win32=yes
CFLAGS="$CFLAGS -mms-bitfields"
LIBS="$LIBS -lws2_32"
;;
@@ -216,7 +219,11 @@ if test $ac_cv_enable_ssl = yes; then
else
dnl If pkg-config fails, run compile/link test.
AC_MSG_CHECKING([if openssl is available])
- LIBS="$LIBS -lssl -lcrypto"
+ if test "$native_win32" = yes; then
+ LIBS="$LIBS -lssl32 -leay32"
+ else
+ LIBS="$LIBS -lssl -lcrypto"
+ fi
AC_TRY_LINK([
#include <openssl/opensslv.h>
], [ return OPENSSL_VERSION_NUMBER; ],