aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c3fafdb4..10c5d1b5 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -105,13 +105,24 @@ INCLUDES = \
-I$(includedir) \
-I$(top_srcdir)/libsylph
+if HAVE_WINDRES
+SYLPHEED_RES = sylpheed.res
+sylpheed.rc:
+ echo "SYLPHEED ICON icons/sylpheed.ico" >$@
+sylpheed.res: sylpheed.rc
+ $(WINDRES) $< -O coff -o $@
+else
+SYLPHEED_RES =
+endif
+
sylpheed_LDADD = \
$(INTLLIBS) \
$(GTK_LIBS) \
$(GPGME_LIBS) \
$(LDAP_LIBS) \
$(LIBICONV) \
- ../libsylph/libsylph.la
+ ../libsylph/libsylph.la \
+ $(SYLPHEED_RES)
AM_CPPFLAGS = \
-DLOCALEDIR=\""$(localedir)"\" \