summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas White <taw@bitwiz.org.uk>2010-06-28 21:29:29 +0200
committerThomas White <taw@bitwiz.org.uk>2010-06-28 21:29:29 +0200
commitcfacbc598926df16e17b37eccbe13e5a712a2d51 (patch)
treeca4687fdcca82a9142e01912be1c9acd7dd6dd97 /configure.ac
parente43cf499d0df41eb6ca2a1a7c21af71e31207635 (diff)
Rationalise and fix KMS enable/disable configure option
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index e2f7ba1..037a98a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -84,12 +84,12 @@ fi
# Check if KMS is to be included
AC_MSG_CHECKING([whether to use KMS])
-AC_DEFINE(ENABLE_KMS, 1, [Define to 1 if KMS is to be supported])
AC_ARG_ENABLE(kms,
[ --enable-kms Include support for kernel modesetting (KMS)],
[case "${enableval}" in
yes) kms=true
- AC_MSG_RESULT([yes]) ;;
+ AC_MSG_RESULT([yes])
+ AC_DEFINE(HAVE_KMS, 1, [Define to 1 if KMS is to be supported]);;
no) kms=false
AC_MSG_RESULT([no]) ;;
*) AC_MSG_ERROR(bad value ${enableval} for --enable-kms) ;;