summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorThomas White <taw@bitwiz.org.uk>2009-10-28 22:12:49 +0100
committerThomas White <taw@bitwiz.org.uk>2009-10-28 22:12:49 +0100
commit0a1c895dab15ef4dbd8f54adedb9be374b532040 (patch)
tree2d455c09aed8e7474b2f1944c2bbec91d2f2c42d /src/Makefile.am
parent66456f91426da900827f85de70d3ce700823ef16 (diff)
parentde692805de0ddbaac9a50734f89e0f6cb99d6846 (diff)
Merge branch 'kms'
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index d229347..a1e8d0a 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -23,9 +23,9 @@
# -avoid-version prevents gratuitous .0.0.0 version numbers on the end
# _ladir passes a dummy rpath to libtool so the thing will actually link
# TODO: -nostdlib/-Bstatic/-lgcc platform magic, not installing the .a, etc.
-AM_CFLAGS = @XORG_CFLAGS@ -pedantic -Wall -Werror -std=gnu99
+AM_CFLAGS = @XORG_CFLAGS@ @DRI_CFLAGS@ -pedantic -Wall -Werror -std=gnu99
glamo_drv_la_LTLIBRARIES = glamo_drv.la
-glamo_drv_la_LDFLAGS = -module -avoid-version
+glamo_drv_la_LDFLAGS = -module -avoid-version -ldrm -ldrm_glamo
glamo_drv_ladir = @moduledir@/drivers
glamo_drv_la_SOURCES = \
@@ -35,4 +35,10 @@ glamo_drv_la_SOURCES = \
glamo-draw.c \
glamo-display.c \
glamo-output.c \
- glamo-engine.c
+ glamo-engine.c \
+ glamo-kms-driver.c \
+ glamo-kms-crtc.c \
+ glamo-kms-output.c \
+ glamo-dri2.c \
+ glamo-kms-exa.c \
+ glamo-drm.c