summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLars-Peter Clausen <lars@metafoo.de>2009-01-25 17:15:37 +0100
committerLars-Peter Clausen <lars@metafoo.de>2009-01-25 17:15:37 +0100
commit3712b1b6b9d77789ac1c5d0dccfb8494a608e6aa (patch)
treef67833cec5dbda1df702e6399bf919c52a95d5d9 /src/Makefile.am
parent5b1749258d20bfb97bc2ec33d92ec2dfad216165 (diff)
Let the damm thing compile with -pedantic -Wall -Werror
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 0fac992..b85ebb2 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -23,7 +23,7 @@
# -avoid-version prevents gratuitous .0.0.0 version numbers on the end
# _ladir passes a dummy rpath to libtool so the thing will actually link
# TODO: -nostdlib/-Bstatic/-lgcc platform magic, not installing the .a, etc.
-AM_CFLAGS = @XORG_CFLAGS@
+AM_CFLAGS = @XORG_CFLAGS@ -pedantic -Wall -Werror -std=gnu99
glamo_drv_la_LTLIBRARIES = glamo_drv.la
glamo_drv_la_LDFLAGS = -module -avoid-version
glamo_drv_ladir = @moduledir@/drivers