aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2019-02-07 16:57:28 +0100
committerThomas White <taw@physics.org>2019-02-07 16:57:28 +0100
commitad5576a5c88dabc4f80b45c0ee9e06dbd34bc46a (patch)
treefb5e39f91e27c33b657dbeed89817f185691cfa5 /meson.build
parent249baac36e5d9b74a4bd435b665221652b267f81 (diff)
Skeleton parser
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build16
1 files changed, 8 insertions, 8 deletions
diff --git a/meson.build b/meson.build
index a102fe4..31d8b83 100644
--- a/meson.build
+++ b/meson.build
@@ -30,18 +30,18 @@ gresources = gnome.compile_resources('colloquium-resources',
flex = find_program('flex')
bison = find_program('bison')
-sc_parse_tab_ch = custom_target('sc_parse.tab.c',
- output : ['sc_parse.tab.c',
- 'sc_parse.tab.h'],
- input : 'src/sc_parse.y',
+storycode_tab_ch = custom_target('storycode.tab.c',
+ output : ['storycode.tab.c',
+ 'storycode.tab.h'],
+ input : 'src/storycode.y',
command : [bison, '--defines=@OUTPUT1@',
'-p', 'sc',
'--output=@OUTPUT0@',
'@INPUT@'])
-sc_parse_c = custom_target('sc_parse.c',
- output : ['sc_parse.c', 'sc_parse.h'],
- input : ['src/sc_lex.l', sc_parse_tab_ch],
+storycode_c = custom_target('storycode.c',
+ output : ['storycode.c', 'storycode.h'],
+ input : ['src/storycode.l', storycode_tab_ch],
command : [flex, '--outfile=@OUTPUT0@',
'--header-file=@OUTPUT1@',
'-P', 'sc',
@@ -49,7 +49,7 @@ sc_parse_c = custom_target('sc_parse.c',
executable('sc2_test',
['src/sc2_test.c',
- sc_parse_c,
+ storycode_c,
],
gresources,
dependencies : [gtkdep])