aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorThomas White <taw@physics.org>2018-03-28 11:38:55 +0200
committerThomas White <taw@physics.org>2018-03-28 11:39:05 +0200
commit3acd99472ac6debed64ce25a0c545c2c9b974ae2 (patch)
treed2cc959c743127df35a2ba45cbcac38716f4c0e8 /CMakeLists.txt
parent665888986b9a3ca629b8fd54965d621296bd56bb (diff)
Stuff for crystfel.pc
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 773d246e..660f3233 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -87,6 +87,11 @@ add_subdirectory(libcrystfel)
enable_testing()
add_subdirectory(tests)
+# crystfel.pc
+configure_file(libcrystfel/crystfel.pc.in crystfel.pc)
+install(FILES ${CMAKE_BINARY_DIR}/crystfel.pc
+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
+
# API docs
find_package(GtkDoc 1.25)
if (GTKDOC_FOUND)